とあるYouTuber編集担当の日記

YouTubeで活動を始めた編集担当です.動画制作に関する知識もほとんどない状態ではじめたのですが,活動の軌跡をせっかくなので綴っていこうとブログも解説してみました

YouTubeは見れるのに他のサイトが見れない

YouTubeは見れるのに他のサイトが見れない

はじめに

先日の記事で公開したように、我が家ではSoftbank Airさんがログアウトし、フレッツ光さんがログインされました。それに伴って、特に上り回線が爆速になったよ!嬉しいよ!というお話をしていたのですが、この度、いくつかのページにアクセスできないという事態が発生しました。その件について、自分の理解している限りで簡単にお話ししたいなと思います。

 

[:contents]

 

現象について

日頃、あまりメンテナンスが行き届いているとは言えないプラットフォーム上でリモートワークをしていたりするのですが、突然、その基盤サイトにアクセスができなくなりました。これは非常にまずい事態で、時間に追われている仕事ができません。

実は、以前からたまにこのようなことがあったので、対症療法的に、以下のようなことをよくやっていました。

  1. サイトのリフレッシュ
  2. キャッシュクリア
  3. 別のブラウザに切り替える

特に順番を意識したことはないですが、このあたりを適宜行うと問題なく接続できていたわけです。(もともとChromeと相性が悪いようで、よくFirefoxに切り替えていました)

ところが、今回は様子が違いました。どれを実施してもうまくいきません。

そのタイミングで気づいたのですが、どうも色々とおかしい。別のサイトにもアクセスが効かないわけです。少し言い方に問題がありますが、繋がるサイトには繋がって、繋がらないサイトには繋がらないのです。具体的にいうと、YouTube1080pでサクサク見れるのに、Abemaには接続できなかったりしたわけですね。(この段階で我が家のAlexaちゃんがお亡くなりになっていることを確認しました)

 

原因究明

ここからが大変でした。普段通り、netstatしたりifconfigしたりするんですが、どーも違和感がなかったわけです。(気づけなかっただけです)

回線速度をGoogleさんで調べると、下りで160Mbpsぐらい出てるし、繋がってんじゃねーかという憤りでいっぱいだったわけです。

このまま待っても仕方ないだろうし、とりあえずシャワーを浴びました。イラつきから冷水を増やしてみて、改めて違和感に気づいたわけです。160も出るか?と。そこで、IPv6でのアクセスになってたんじゃないかということに見当がついて、ネットワークを確認すると、やはりIPv4のインターネットアクセスがなしになっていたわけです。

ようやくここまででとりあえず原因はわかりました。

 

どこで問題が起きているのか

モデムとルータだけの簡単な構成ですので、どちらかで異常があった(設定が変わった)のだろうと考えました。IPv6はビュンビュン飛んでいたので、間違いなく光は家まで来てるわけです。

それぞれのLANを確認してみると、案の定モデムのところではIPv4アクセスが効いているわけですね。これで完全にIODATAのルータに問題があるということがわかりました。

 

ここからが賢かった

予定がありました。その前に終わらさないといけない仕事もあった。ということで、実はこの段階で、ルータを通さなければそのまま接続できんじゃん!と気づいたので、それでひとまず仕事を終わらせ、今に至るというわけです。

 

今後しないといけないこと

新しく編集専用マシンを購入したので(今度スペックなどの話はしたいなと思います)、この問題からは逃げちゃいけないわけです。(今のまま優先で対応するのもまぁありなんですけど)

とりあえず、色々調べてみるとルータ自体の仕様上問題はないはずなので(やりたいことはできるはず)、そのうちちゃんと対応します。

 

まとめ

YouTubeつなげんのに、他のネット繋がんねぇじゃん!ってなっている人は、IPv6だけになっているんじゃないかと思います笑。なので、急ぎの方は大元のアクセスポイントに繋ぎにいくというのが、ソリューションのうちの1つだということを提案しておきます。改めて、ルータの方の何が悪かったのかを特定次第、更新していきます。

 

****

過去記事

 

www.brian-tee.work

 

 

www.brian-tee.work